Audio source failed to initialize audio spatializer. Please check that the project audio settings and make sure that the selected spatializer is compatible with the target

I am running into a bad spamming error in unity:
Audio source failed to initialize audio spatializer. Please check that the project audio settings and make sure that the selected spatializer is compatible with the target.
I have tried to look for solutions online, I can only find ones pointing to microsoft mixed reality things and i’ve tried adapting fixes for that to my project but nothing is working.
I constantly get a spam of 999+ errors in the console continuously when trying to test in unity.
is there any way to fix this at all?

6 Likes

following… as I have the same issue. Appeared after migrating a Unity 2019 project to 2022

Same, this happen to me after migrating

try this
click edit and scroll to project settings


then under audio

select none under spatializer plugin
image
hope this helps

Does not fix the issue! If OculusSpatializer is disabled as suggested - the following error is displayed:

Screenshot 2023-12-17 132312

Pressing the Set Audio Specializer re-enables the OculusSpatializer!

same when i tried today. :confused:

try removing client sim and try uploading a test version
or
try reimporting the Vrchat SDK

it appears to be a bug in the VRchat SDK V3.5.0: * Spatialized Audio Sources can create warnings when entering playmode or adjusting their settings.

I guess we wait to see if it gets fixed anytime soon.

My current work around is to delete the vrc audio spatial component and unchecking spatial in the main audio component. It seems to still do the spatial audio. It says during upload that this way is deprecated but until they fix it, it works.

Import Oculus Spatializer for Unity resolves this for me.
https://developer.oculus.com/documentation/unity/audio-osp-unity-req-setup/
Just for information.

I just tried that and it caused errors that would not remove and caused the “scene cannot update” error.
I also tried to install the whole meta XR all-in-one SDK to see if it was missing something and that has also caused this stop error in at least 44 of my assets: Assets\Thry\General\ThryAction\ThryAction.cs(145,25): error CS0234: The type or namespace name ‘IsValid’ does not exist in the namespace ‘Utilities’ (are you missing an assembly reference?)

[EDIT] after removing the all-in-one SDK and adding in only the audio and the core SDK it still comes up with the spatializer spam error in unity.

Following, I have the same issue.

New to VRChat, been working in Unity for years.

Bringing over Worlds by opening them via the CreatorCompanion and everything I need is added etc. so I can test as if I was in VRChat. When I run the game though, I get these errors for each audio source I have in my overworld.

I can’t help but wonder if the expectation from VRC support is that the users should fix this. What would we check to confirm compatibility?

Please check that the project audio settings and make sure that the selected spatializer is compatible with the target.

Would someone from VRC (please) acknowledge that VRC has seen the warning occur in their projects? It is a warning so not expressly an error and the audio seems to work regardless but this is not something the developers should have to guess at.

Again… we see threads about “communication” and example after example of zero communication.

I get these warnings as well BTW and I would be interested if each person who develops worlds could reply with either they do or do not get these warnings. The problem is that so few people use this site for support that even if every developer sees the warning only a handful will post anything about it.

1 Like

Is there a feedback item for this? This board isn’t normally monitored for bug reports. In the future, make sure you post bug reports there!

For this item, I’ll surface it internally once I can gather more information.

Can you provide:

  • Reproduction steps - How do I make this happen?
  • Example projects - Can you provide a project where this happens?
  • Minimum reproduction setup - What is the absolute minimum project where this happens?

That info will help our engineers fix the problem.


Just got some clarification:

Yeah, we had to ask Unity to investigate for us. It isn’t our bug. In short, the Oculus library broke some things. This happens even in totally vanilla Unity projects.

We have a fix waiting for QA that does some plugin swapping to use an older, non-broken version instead.

As developers we can appreciate the problems that can sneak in but as a professional software developer I have to wonder why regression testing wouldn’t have turned up this issue. I would have thought VRC would have a dozen or so small projects (worlds and avatars) using various popular libraries and Unity components.

If not then it really should be a regular part of regression testing. We can surely help report unusual errors but if for example OnDeserialization breaks an automated test probably should have seen that.

Any updates on this? I’m having major issues been trying to fix it for two days now and have an event to run in a few days. Been sweating buckets :sweat_drops:

Nope, still waiting on Unity to fix. We have a workaround that may be viable but no ETA on its release.

1 Like

Looks like we just pushed a SDK update that should fix this issue! Release 3.5.1 | VRChat Creation

2 Likes