Vrc spatial audio source functions in clientsim, not after upload

when testing my worlds with ClientSim, sounds work exactly as I desire, but upon load to vrchat, the worlds are silent. Any ideas on what to check?

You mean your entire world is completely silent? How strange.

What happens if you remove the VRC_SpatialAudioSource component?

yes, completely silent. If I remove the vrc spatial audio source,
then the Max Distance setting on the Audio Source component is ignored
(in ClientSim). I’ve not uploaded the world without the vrc component
as the max distance setting is important.

removing the vrc component, then attempting to republish to vrchat
give a warning about a missing vrc component (which I clicked the
“fix” button) to add it back in, then upload proceeded.

the result: same silence.

I also tried with both the Enable Spatialization and Use AudioSource
Volume Curve options both checked and unchecked… still silence.

AND i’ve assigned a 100db gain… no sound.

ok. removing the vrc spatial audio component and tweeking the
AudioSource component to just ignore spatialization works… sadly,
but it works.

1 Like

I’ve also noticed if you create a 2D audio source without the 3D spatial audio component the “Autofix” ads one but it also disables the sound making it silent.

You can ignore or remove the component (or set it to 2D) then it works, but yes you lose stereo separation. In my experience this seems to happen more on Quest (Android) worlds than PC.

This may be klunky, but as a workaround I’ve copied the audio settings from one of the speakers in ArchiTechAnon’s ProTV Advanced prefab (there are two, one left and one right, as well a ‘center’ channel in the TV) then my objects behave correctly.

I don’t know if this is an SDK issue or if there’s an obvious and easy solution we’re missing.

I have a world in community labs that relies heavily on spatial audio for it’s desired effect (8 separate sources in a circle that you stand in the middle of) , so looking for better solution to this as well.