VCC Error

keep getting this error, ive reinstalled many time still no fix. need help.

Did you use the right version of unity and the latest version of the sdk?

Also, not sure to understand the relation with vcc

Latest, and i put vcc cuss i presumed its a error code with vcc but if it is not then u are allowed to correct me on that seen as i have no clue how fix or what the problem is.

If you are using the latest version of unity, that’s probably the reason why. VRChat requires a specific version of Unity to work.
You need to install the 2022.3.6f1 version

ye latest for vrchat is whut i mean

1 Like

I tried again rn by starting new project and I got the notification for either safe mode or ignore as usual, I clicked ignore this time and all these new errors appeared. Including the same error as before. Does this change anything?

When you create a template you select the template for unity 2022 avatar right?
Else maybe something is removing the sdk files.

Anti-virus maybe?

Yes of course and I have no anti virus.

I’m out of options myself sorry.

It seems I learned something today about what packages require other packages.

If you can reach your Package Manager through Window > Package Manager at the top of the Editor, then try to go to the advanced settings (the 3 dots next to the search bar) then to Manual resolve, which will try to reinstall altered packages and hopefully fixes this issue.

Otherwise (With Unity Closed) you might have to go to your unity project folder then in Library > PackageCache and delete com.unity.ugui@1.0.0
Then when you reopen the project it will attempt to reimport that package.

For a more technical explanation:


the error is referring to this line of code

where it seems that your copy is trying to construct ObjectPool with 3 arguments instead of the 2 it normally is if my understanding is correct (which it probably isn’t lol)

If that doesn’t work there might be more at play then is shown or just aspects I’m not thinking of, good luck.

1 Like

I will attempt!