Uploading World SDK Issue

SDK Version: 2022.

Greetings, I’m having an issue where my world builds appropriately and can be ran locally in test. However when I go to build to publish I get an issue that is referencing the SDK 2 namespace.

var desc = pipelineManager.GetComponent<VRC.SDKBase.VRC_SceneDescriptor>();

I have downloaded the latest version from the VRChat home website of the World SDK. I even opened up a new project clean and imported the asset library there as well but the file still shows up. I’m gathering that since it is a dependency it makes sense as being from the previous SDK. So, that leads me to look to see why the Scene Descriptor is coming up as null. I look at the VRCWorld it does appear to have a VRCScene Descriptor.

Thoughts as to what I may be missing? I did see a post about multiple pipeline managers however I appear to only have one.

P.S.: I also attempted removing the script as per the directions in the sticky, though I had to reload the SDK as it did not appear to recompile the script.

Solution Found

Found the solution in another forum post. Apparently I did have a second pipeline manager on another object without realizing it. Searching for it in the hierarchy for “PipelineManager” brought up two objects with it.

I first tried to disable it from one object and that corrected one issue. But then the upload screen would not appear on the Game tab when build and publish was performed. I had to remove the component entirely. Now it works.