My avatar lags for other people

Rig:

CPU
AMD Ryzen 5 2600X Six-Core Processor
6 Cores
GPU
Radeon RX 590 Series
Primary/Discrete
VRAM
8192 MB
GDDR5 2100 MHz
RAM
32 GB

I have 76 fps, I have 195 ping stable doesnt chance much other like like 5 up and down, Im playing the game on desktoplow settings, almost all of the safety settings are turned off like I dont see peoples avatars, avatar voice, animations, shaders, lights etc. even for friends only avatars and speaking etc. are on, I also have avatar limit of 100mb, I make the game work on high priority, all my drivers are updated.

The game is super smooth for me, my voice is also smooth to others but for some reason my avatar keeps teleporting around for others if i stay in an instance for longer than 10 minutes. I always check my ping too it is always stable. But when I reopen the game it gets fixed. My cache is always below 5gbs I clear it almost everytime Im leaving the game or when it lags.
I’ve searched many discussions about it and tried many other things. Even all the firewall and antivirus of windows 10 is disabled just in case if its the one bothering it. I dont have any other antivirus or third party app like that too. I only run with discord and steam(+vrchat obviously). People with worse ping like around 300-350 doesnt teleport still. I still dont know what could be the problem and Im gonna go crazy over it. If you or anyone can fix it, can you help me out too? I have the same name inside the game and on Discord and other platforms like Steam etc too.

Im using an avatar with excellent performance. It doesnt have anything on it and animation of my avatar looks fine (for this avatar atleast) but for some other avatars with animations, it doesnt look fine but they had poor performance so i got rid of them. Depends on people too. For some people im lagging for some im not.

avatar lagging means the optimization is at fault, you dont lag because your descriptor does not face your avatar. a mirror does not entirely reflect every feature of your avatar.

But the problem exist with default legacy/non-legacy avatars too not to mention the one I was using had excellent performance. So Is that a problem on VRChat’s behalf then? But If so then why is it not happening to many others only in some rare cases to a few?

shader can lagg some one even if the avatar is at excellent performance

All the shaders and light particles on top of sounds and animations are turned off. Even icons and avatars are turned off for visitors, new users and users. Only voice so they can talk. Shader and particles are turned off for everyone even for friends. And I dont think default avatars has shaders that can lag.

then i don’t know how is it lagging until I see it my self

Hey, I’m having the same issue. I always have people to tell me when I’m stuttering cause it’s not visible on my end. Have you by any chance fixed it?

Sadly no. I have to reopen the game every 30 minutes to fix it which isnt fun. And sometimes it doesnt fix it for some people either.

If it’s your overall movement running at 2-8fps only for others then I see that often happening to some specific people, even confirmed through streaming. It doesn’t have to do anything with avatar being worn.

This has been a problem for such a long time I honestly dont even know what to do anymore. And the thing is when I rejoin every 30 mins it never lags. It does that after playing on the same instance for more than like 20-30 minutes.