Game stuttering severely since EAC update/can't change process priority

Since the most recent updates I have been experiencing really bad stuttering both in desktop and even worse in VR. Originally I had followed a guide for changing the process priority from Normal to High in task manager when this had happened, but since the EAC update I have been unable to change the process priority, getting met with “Permission denied. Unauthorized access” from task manager. I can change other process in task manager still, and I am already set up for administrator permissions.

For VR the only temporary workaround I could get was setting up motion smoothing in Steam VR, which causes the game to lose more frames when activated and has caused some tracking issues for me too. I also have tried unplugging my secondary monitor, but no positive change was noticed. I’ve gone ahead and attached an image of what the performance graph shows before motion smoothing is turned on and with the second monitor disconnected already.
unknown-215

Specs

-MSI B550 Tomahawk
-AMD Ryzen 7 3700x
-32GB DDR4 Memory
-6GB Gigabyte GTX 1660 Super OC Edition

there is one option that might help. Reinstall not just Steam VR, but Steam itself

2 Likes

Could I ask how that would help? No other SteamVR or Steam games are having this issue (especially none that already have EAC, like PavlovVR and Dead by Daylight), so I can assume it’s not an EAC problem.

Apparently it doesn’t help. It rather helped people who had problems with the virtual desktop and reinstalling steam vr didn’t help, but reinstalling steam did. If in that case setting priority helped, in the latest developer update developers are going to add such a feature, so we have to wait

CPU Affinity

Next up is looking into defining process priority as a launch option.

2 Likes

The thing is I don’t know what I need to set mine to for this to work. They just say to look around for other people’s configurations, but searching around has lead me to no results.

I did a bit more looking into it finally and tried to apply that affinity bitmask thing, and no changes came out of it, so I’m out of things I can think of trying.

Have you tried adjusting settings in the Nvidia control panel? I haven’t tried what this article suggests with my GPU, but there’s a chance it could help you out.

I have also been having this same stuttering issue shortly after EAC was implemented. The only difference is that I’m using an AMD RDNA2 Graphics processor. So far the only thing that has solved the shuddering was my GPU driver completely crashing. I’ve heard that other games that use EAC, such as Elden Ring, share this issue.