Avatars and some worlds not loading randomly at times

Hey y’all! This could be caused by any number of network inconsistencies, though it’s suspicious everyone seems to be having new ones at a similar time. I don’t believe we’ve updated anything instrumental in our bundle downloader code recently.

A couple things:

  • Check in C:\Users\AppData\LocalLow\VRChat\VRChat\output_log_*.txt. Whenever a file fails to download you should be seeing some errors there, that’ll hopefully give us a bit more to go on.
  • Shot in the dark, but do any of you have Killer Intelligence Center or similar installed on your setups? A friend was able to trace their issue back to that, and they started having issues around the same time. Their log included messages saying “Unable to complete SSL connection”.

@Feilen To add to this, any program that may apply QoS (Quality of Service) or Traffic Shaping to a network adapter or interface on the machine could cause this. Netlimiter is another big one.

Disabling IPv6 is not necessarily a solution to a problem rather a solution to a symptom of a bigger problem. It should almost never need to be disabled.

Yeah, any number of things could cause it. I’m curious if an update to that particular software could be responsible for the recent uptick though. Worst case, we now have something I can install to break it on my end and figure out a fix…

There really wouldn’t be much you can do, it’s a software bug on their end. It also affects more than just the vrchat program. What I believe is happening is it’s breaking the IPv6 stack inside of windows, hence earlier me mentioning that disabling v6 is a fix to a symptom not a problem.

I am also having this issue. It started about a month ago. When I go to the worlds menu, the thumbnails won’t load. Many of my avatars show error models. I have Norton 360 and it’s both annoying and strange I have to enable a VPN through that to get VRChat to work properly through Steam.

I HAVE A SOLUTION THAT WORKS!!!

You need to, on windows 10:
Go to Control Panel → system & security → windows defender firewall → allowed apps. Delete VRChats entry from the allowed programs list
THEN
Go back to the Windows Defender Firewall settings, click on Advanced Settings, Go to inbound rules in the window that opens, look for VRChat there, and delete all entries there.

This essentially resets VRChats permissions & settings on your network. Open VRChat, allow it through the firewall again, and it will start working properly again!

I can confirm that this does not work, at least not for everyone. It has been months now and VRChat download servers still have this issue, come on, what a joke for the community. Figure out what the problem is and fix it please, in my case it has been happening since December, stopping for around 40 days at the beginning of the year and now for the past 3 weeks has been happening more and more to the point where it’s becoming unplayable. It may be a coincidence, but it started happening more and more in The Great Pug, as well as happening much more when I’m there than in any other worlds. In any case, please VRChat team work on fixing this or at least giving us a way to fix it ourselves.

Alright, I think I have finally found a permanent fix after months of trying. If the problems come back I’ll edit this message to let y’all know that it wasn’t permanent.

Something worthy to mention is that if I try to access Cloudflare’s https://1.1.1.1/ address that @docteh posted months it still won’t load, however the VRChat download instability issue seems to be gone so that’s what matters.

What fixed it for me was manually setting up Cloudflare’s DNS for my PC and my router, here is a very easy guide on how to do that: Set up Cloudflare 1.1.1.1 resolver · Cloudflare 1.1.1.1 docs .

It seems that by manually using Cloudflare’s DNS it always makes a successful connection to VRChat’s download servers which @docteh mentioned in the past have Cloudflare DDoS protection, and the very unlucky few of us who have been struggling with these issues have DNS settings likely automatically set by our ISPs that struggle to connect to them consistently. It is very odd since I assume many more servers are protected by Cloudflare but only the VRC ones were an issue, however this also would explain why in my case the issue went away almost completely for a month and a half since probably what happened is my ISP changed some settings by themselves, then changed them back when the issues happened again.

Again, just set up your DNS settings to use Cloudflare’s 1.1.1.1/1.0.0.1 DNS and it should be good to go. Like I said at the beginning of my post if this ends up being only a temporary fix and not permanent, I’ll edit this comment to let you know.

Edit: It isn’t a permanent fix. AAAAAAAAAAAAAAA

googles public DNS works. iPV6 one specifically.

This is an actual, good, at least 2 day working fix.
official google guide to setting it

As an aside, this also fixed the issues i was having with loading into Yu-Gi-Oh Master Duel. so, it’s a working fix for this in my books

okay so just as a heads up. This sometimes stops working, in that case, you need to hit “Automatically get DNS server”, and then back to “Use the following DNS server”. Works again after

Seems to me that changing DNS works temporarily but not for long, I had also tried Google’s DNS when the problem started and it wasn’t consistent either. You know what would be cool, some help from the VRC Team on figuring out where the issue is. But I guess since we are like 10 people total it’s not worth the time. Yes I’m salty lol, it’s been over 3 months!!!

hard restarting my router fixed thiis??? the ONLY difference is that my results from https://test-ipv6.com/ show that i now HAVE IPv6 available???

edit: only… in desktop…???

Still experiencing this issue after trying every possible thing in my power… At this point, only thing that has worked has been VPNs, however, most of them are blocked by VRC…

Does cloud flare warp work? It’s like a VPN in that your traffic is encapsulated, but in the sense that cloud flare is probably not hiding your identity from cloud flare.