Avatars and some worlds not loading randomly at times

Since last update, it looks like vr server going poop all of a sudden when it comes to downloading stuffs. then few minutes later it starts to dl again and etc. Usually have to restart game to try to fix it.

Everything else is good, ping included, but for some reason, sometimes the game decides to not load stuffs and this is quite bothersome.

Never happened before. This is quite disgusting.
Reinstall, clean full cache done, nothing works. happens on vr and desktop.

1 Like

Ive been checking what the issue could be and… it seems that Vr chat is using another exe which is the usual Unitycrashhandler and is the culprit of the issue. The game also, because of it, can freeze upon exit.

force close the task fixes everything… or not T_T. It comes back if I check dl lots of stuffs now. never happened before.

I always laugh wherever I get a unity crash screen when I close VRChat.

I haven’t had to force kill anything for VRChat yet, but I have had to force close the unity editor a few times

I sincerely have no idea whatr is happening, game literally dl things pretty fine, then sometimes it just doesnt even want to load av images at all, literally something blocking dls (sounds like game server and dl server is separated, because I have 0 lag and can play pretty fine)

Unity crasher pops up every now and then out of nowhere too.

Its like dl server are on a dial up sometimes and they be dying, its really annoying

I have the exact same problem, sometimes the worlds and avatars dont load or are stuck at 0% and maybe after a restart or waiting it finally works. Its so annoying.

Having the same issue for the past couple of days, I’ve tried every possible fix for every possible similar glitch online and nothing. Tried troubleshooting every local file installed, changed network adapter DNS, disabled IPV6, ran the game as administrator… absolutely nothing works and only thing someone mentioned in a Steam forum was that it fixed itself after some time. Feeling pretty desperate

Having same issue as people above

Here’s a screenshot of the issue, after a certain number of avatars, they will stop downloading and i’d have to clear cache again for it to restart. You can see all the people’s avatars at 0% downloading no matter the size

yep, nothing works. I unistalled, clear fully cache, change size and cache place, logout, restart, safe mode, etc… Nothing works.

my net be fine, ping great and stable, can talk and play smoothly, but downloads (avatars and avatar images mostly) stops working sometimes.

I personally think it has to do with something on the devs/third party’s end doing weird poop on us, and download server be wlaking with one foot,

Usually happens in peak hours for me. Then it works fine again.

They really need to check their shit

I have a suspicion that this advice made sense for a single month of VRChats existence. Hopefully you put it back. Compared to ten years ago, stuff actually can use ipv6 these days. It’s probably fine today, but there will eventually be a tipping point where disabiling ipv6 will kind of break internet address

Danger here is that any file created while running as administrator is protected from pesky regular users, personally I’ve chosen to nuke VRChat from orbit over running as admin.

Since VRChat is likely behind cloudflare for everything I’ve suggested cloudflare warp a few times. I haven’t searched these forums to see if anyone’s had success or not with that. So it’s quite possible that using cloudflare warp results in you being kidnapped by ninjas…

I really hope there is a fix other than reinstalling Windows, as the only other reply I’ve read that wasn’t the Steam person saying it got fixed by itself, was someone else saying VRC support stopped answering them at all. At the very least I’m hoping for a reply from support to the ticket I submitted, I suggest you do that too if you haven’t already. I know this is a relatively rare issue, but ugh… In my case it stops downloading any assets as soon as I load into the game. Loads home world, the avi I have at the time of launching and 1 more world, but nothing else. No one’s avis, no other worlds, and very few menu thumbnails. It’s unplayable when the main appeal of VRC is socialising while in VR. Please devs, look into this because the game as it is for whoever has this issue is literally unplayable. Discord serves the same purpose when all I can do in VRChat is voicechat with people I can’t even see in my home world.

I don’t think you need the “relatively” qualifier, it is a rare issue from what I’ve seen. I have 70 friends on my VRChat friend list, one of them had this issue loading assets, I found a suggestion about cloudflare warp a month later, passed it along and they were back on PC the next day. I haven’t gotten any feedback so maybe they reinstall Windows lol

Buy a Cheap ssd, install but don’t activate windows.

Problem like this has two sources,

  • Something on computer
  • Something involve internet. From your router, through your ISP to cloudflare

Maybe your router is somehow twenty years old and you’re exhausting a connection limit? I wouldn’t expect a game support to figure that out in a reasonable amount of time…

I personally think that has nothing to do with it. It is indeed a rare issue.
Oddly I hear the prob happening usually outside US maybe?

Game was fine before, just happened on new update (updates always have problems, this is a constant by now it seems)

ssd or hd dont matter, the issue still the same. This looks like a loss of packages/connection and the server (or something around it) not being able to cope it out, going on dial up, while having good and stable conection on personal side.

-stable ping/conection.
-good hardware.
-only vr chat gives problems.
-appeared since last update.
-can play fine, dl is the only problem, which seems to be separated from the rest.
-0 help, nothing works.

The problem is on their side, or on one of their third parties doing something weird.

It feels like a firewall that decides to stop dl conection, resulting in an error on dl process and crash the whole sharing of packages.
Or maybe the server expect 100 mbs conection and times out once in a while in peak hours because of it if you dont have it?

I am no expert, however, but my idea is overall more realistic so far.

What usually works for me, also not a permanent fix… is restarting pc or router. the problem, when happening, while have high chance of coming back once more.

tThe issue is indeed really problematic and hurts the core of the app-
Kill the unnityhandlecrasher from task too, nobody wants that shit running for nothing.

Yeah same, computer is fine, router and connection are fine, everything works plenty fine except for the downloads inside of VRChat. Only thing I haven’t tried is that cloudfare thing but I’m not even sure how, and up until a couple of days back it was working fine as well anyway so egh. Hoping it’s something that will be fixed on an update or something…

Its freaking odd because anything could trigger the bug/error, from menu, av pedestals, avs, worlds, etc… Like anything that requires some downloading can randomly (but on specific times, when it happens it happen constantly, and “fix” itself later and everything is alright again) trigger the issue. I really think the problem is based on the dl server not coping with something due to it, but idk.

Oh, and everytime it happens, Vr chat doesnt want to close itself and have to be forced to end the process, every time. There is definitely a bug here.

Its imposible to dodge it when it happens as far as I know.

1 Like

Also worth mentioning that sometimes after I clear cache manually in appdata folders, I can’t even dowload the home world. Sometimes no matter how many times I delete cache or try fixes, it won’t download anything besides home world. Not my avi, not one single menu interface icon/thumbnail. And some other times I can join a 120MB world with 50 people and download every avi, but then if I try to switch worlds I can’t download anything again. Even a friend’s avatar which had loaded in one world didn’t load when they followed me into the second world (I had both worlds in cache downloads, thats why I could join two of them). It is absolutely random and does not follow any pattern or rule that can indicate what specific problem it is

Agree with what @itsthatmia and @Endelu have described. Also responding to the “outside the us” thing, yes, I’m in Europe has links to it, I haven’t needed it so I haven’t tried, but it’s got desktop client to run. I’m curious if you need a account or not

More info I can throw in here about my case in particular hoping that someone may know what it is. I am also from Europe so the “outside the US” thing applies here. I have some group policies on my PC and some registry key edits but they all work around my computer not turning on by itself at night for updates, updates having to be manually downloaded instead of automatic (yes I’m up to date), and the Windows 11 search menu not showing up internet search results and only local (I had this key enabled before the VRC bug started happening). I mention these things since some other VRChat bugs can be fixed by deleting the VRC registry folder, and maybe someone can find a link between those two. Been a couple of days and it shows no sign of improvement :confused: Unfortunately I can’t access the website @docteh mentioned above so no coudfare thing either

Really? Four ones, throw a dot in between each one, and can’t load there? One dot one dot one dot one…

If you can’t access that, I wonder if you’re somehow blocked from cloudflare, VRChat likely has the asset servers behind cloudflare ddos protection.