Unity|VCC Console Error When Uploading Avatar

I am having an issue with uploading my avatar. Everytime I try to upload it I get this error and it says upload failed. I attached a picture of the Pipeline Manager to show when I upload it, there is nothing in the blueprint ID when I press the upload button. I am able to build and test it fine.


Screenshot 2024-03-06 022934

I’m also having the same issue on my end, everything is working fine till I upload then fails. Sometimes for me it’ll also say ‘timed out’. I havent found an answer but hopefully one comes soon.

Hi, @_Queenie ! In your screenshot, I see that you experienced the following error:

Attempted to load the data for an avatar we do not own, clearing blueprint ID

The blueprint ID (or “avatar ID”) is your avatar’s unique identifier.

It seems like you are attempting to upload an avatar that has another user’s blueprint ID attached. This often happens when a user shares an avatar’s Unity files without clearing their own blueprint ID first.

Normally, the VRChat SDK will try to clear the avatar’s blueprint ID if it’s invalid. But it seems like you may need to do it manually in your project.

Try selecting your avatar in Unity’s hierarchy tab and clicking “Detach” in the “Pipeline Manager” script.

Hope this helps!

That doesn’t help unfortunately. If you also see in my screenshots, there is nothing in the pipeline manager to detach. No blueprint ID to detach but it keeps giving this error.

If you also see in my screenshots, there is nothing in the pipeline manager to detach.

Oh, that’s right! I hadn’t read your post carefully, thank you for pointing that out.

In that case, I don’t see an immediate solution to your problem. I’m confident that the actual solution will end up being rather simple - but until then, it might help to narrow down if it’s an issue with the avatar or with the SDK. Are you able to upload the SDK’s example avatar?

Unity_IB6fg1tLUM

If the example avatar can be uploaded correctly, then there might be something unexpected about your avatar or one of your Unity extensions.

There’s also the chance of an issue on VRChat’s end.

If you’d like to provide additional details, feel free to post your Editor.log file. It contains additional information that isn’t visible in your screenshot. Note that the file might contain personal information about folders or files related to your Unity project, so consider sending a shortened version that only contains your errors.

Here’s how you can find your log file: Unity - Manual: Log files

The same exact thing is happening to me. Even tried uploading the sample. Same error, cant upload anything (I can test Avatars). I NEED this fixed

Did anyone figure it out?? I’m having the same issue and I have tried everything!!!

Hi Fax…I now tried uploading the robot and the SDK is stuck on “Checking existing records…” I cant seem to upload anything due to the same errors mentioned by the other people in this sub. I am logged into my VRC account and have had no trouble uploading avatars before so I’m not sure what’s going on

I also received the same errors when I tried uploading my avatar. I went back to an avatar I uploaded approximately 9 days ago and now it gives me the same error when it didn’t before.

This only occurs on projects using unity 2022.3.6f1. Projects using unity 2019.4.31f1 are just fine and I am still able to upload using them.

I am not sure why I’m having these issues now and would hopefully like it to get fixed soon as newer avatars use the 2022 version now.

I saved the Editor.log, but I am not sure on what information I need to delete and where exactly only the errors are located. I also don’t know where I need to share the file.

1 Like

The newest SDK version throws this error in the console no matter what the issue is, just found that out after some searching, was getting this exact error, went through the console and fixed the other error within that was unrelated, and the upload works just fine, go through your console and check for other compiler errors, because regardless of what the real problem is, the console is going to throw the blueprint ID error at you aswell, hope this helps



A friend told me to try using a VPN since it seemed to be something with VRChat and my ISP. I used a VPN to build and publish and it worked this time. I recommend trying this solution in addition to what @Rakasai said.

Thank you Rakasai and Sleep. Both of those solutions paired together helped! :slight_smile: <3

You are so lit. It was literally just the VPN that made it all work

I was getting the same error “attempted to load the data for an avatar we do not own.”

I reset my password via vrchat.com and created a new project with a new sign in to the SDK. Then the SDK upload started working for me. Hope this helps for others without needing a VPN.

what if it says “error saving prefab” on EVERYTHING

Having the same issue, getting the error message “Attempted to load the data for an avatar we do not own” while there is no blueprint ID to detach. I have a VPN and using it does not help, even tried turning it off.

Update: Before posting this reply, I decided to go through the tutorial I was using again, and I found out I missed a step. I forgot to unpack the prefab. Once I did that, the other steps, like removing missing scripts with FACS, worked properly and I was able to publish it. Still running into other problems, but if you run into this particular issue, you might have made the same mistake as me.

got the same problem can you send a link to the tutorial ??

HELLO! Simply downgrade the project to the old 2019 supported version of Unity. Then try again.

HELLO! Simply downgrade the project to the old 2019 supported version of Unity. Then try again.

Hey guys, my solution to this problem was that i added VRCFury to my project and suddenly it just worked. Not sure if this was a one off thing but it seemed to have helped

1 Like