[Solved] WindowsVideoMedia error 0xc00d36b4 with video players

I get WindowsVideoMedia error 0xc00d36b4 every time when I try to play youtube videos on video players, no matter what world I’m in.

This bug has been bothering me for months. Everything was OK when I first played VRC, but one day it broke and it’s never been fixed.

I tried reinstalling VRChat, installing codec for Windows Video Media Player, updating the graphic card driver, and every possible solution I can think of.

Is there anyone who know how to fix this issue?

Below is a portion of the output log, which shows the error message.

2023.01.09 21:59:42 Log        -  [iwaSync3] There was a `PlayerError` error in the video.

2023.01.09 21:59:42 Log        -  [iwaSync3] Emit event of video error caused by `PlayerError`.

2023.01.09 21:59:44 Error      -  WindowsVideoMedia error 0xc00d36b4 while reading https://rr8---sn-bpb5oxu-3c2r.googlevideo.com/videoplayback?expire=1673294380&ei=zB28Y_i4MYn-qQHHpZeoDw&ip=2a09%3Abac1%3A7460%3A28%3A%3A50%3A8b&id=o-AGVR-lPqU484TnSyYWO9aBZ9tLaFo0aSzhNE7A9amQr9&itag=18&source=youtube&requiressl=yes&mh=2R&mm=31%2C29&mn=sn-bpb5oxu-3c2r%2Csn-npoeene6&ms=au%2Crdu&mv=m&mvi=8&pcm2cms=yes&pl=64&initcwndbps=302500&spc=zIddbKWmwEXLc352xhKkoNjG2p0Yedk&vprv=1&svpuc=1&mime=video%2Fmp4&cnr=14&ratebypass=yes&dur=244.459&lmt=1665700770486928&mt=1673272445&fvip=1&fexp=24007246&c=ANDROID&txp=4530434&sparams=expire%2Cei%2Cip%2Cid%2Citag%2Csource%2Crequiressl%2Cspc%2Cvprv%2Csvpuc%2Cmime%2Ccnr%2Cratebypass%2Cdur%2Clmt&sig=AOq0QJ8wRgIhAOrTXcz2Vt6KNbt1B3gfFl7CGeUAWUJ5kIwZxxYBnz8BAiEA8N-saw6ol1Vo3LeLw91ImmSWIk8LKzM2gCHaZENqm0Y%3D&lsparams=mh%2Cmm%2Cmn%2Cms%2Cmv%2Cmvi%2Cpcm2cms%2Cpl%2Cinitcwndbps&lsig=AG3C_xAwRgIhAK6VRgTBVYm4EW4aAgHOzHESzvGxS7oEXPsI3swMiC-tAiEA7jXmmR0REhy12sxgjqh6M8FhDF-I-xe-q6MKteZFPKU%3D

Context: IMFSourceReader::WaitForSample in StepAllStreams
Error details: The data specified for the media type is invalid, inconsistent, or not supported by this object.
Track types:
   Unreadable Track

I’m pretty sure that “iwaSync3” isn’t the problem here, because other video players preformed the same issue on my computer.

Oh and the “Omokage music video” I was playing when capturing the logs wasn’t the problem either. All videos on all media platforms cannot be played at all, and the same videos can be played on my friend’s computer.

I joined the official VRChat discord server and took a look at the #user-report channel. Someone there was experiencing the exact same problem as mine!

And @ Whiren replied with the solution: Turn the fast v-sync in nvidia panel off

That worked!! The problem solved!!

Gonna leave this topic here for anyone who are facing with the same issue : )