VRChat (on PC) refuses to start

I played VRChat many times using PCVR but recently (I believe after the last update) it no longer runs from the Quest app (Windows 11). I can confirm that other games do run. I have uninstalled and reinstalled several times I don’t think that’s the issue.

I click on the icon it seems to start and immediately closes. I don’t see any part of the VRChat app actually start. I tried briefly using the Steam version and it doesn’t run either.

Has anyone experienced this recently? Any ideas about how to debug the issue?

I don’t see any logs. Just now uninstalled and reinstalled. I was able to see all the app-related files were removed and then reinstalled. Game won’t start on Quest 3 using air link or link cable. It won’t start in desktop mode either.

Tried to run launch.exe directly doesn’t run. Tried start_protected_game.exe doesn’t run. Tried VRChat.exe and it runs but tells me it is in offline mode.

Does anyone have any ideas as to what could be wrong?

Do you play other games with anti cheat I wonder if EAC needs to be uninstalled and reinstalled

I did wonder about EAC and that perhaps it got confused by something that looks like I’m cheating. Thanks for reminding me to look into it. The service is set to manual and it is not running. When I try to start it, it reports “the parameter is incorrect” and it does not run. That sounds like a clue to me.

I tried reinstalling it using EasyAntiCheat_EOS_Setup.exe (apparently there is a repair option there as well) but I’m not getting any sort of UI (I ran it as admin).

I have to believe this is the source of the problem so now at least I have clues and can work from there. Thanks.

I uninstalled VRChat again. Then removed the service, then deleted the EasyAntiCheat folder. Figured that removed any remnants if that was the cause of the failures. Reinstalled VRChat, it prompted me about EasyAntiCheat, I accepted it. The folder and service is back.

The app does not run in Desktop Mode or with AirLink and still starts up/shuts down immediately. No VRChat log as far as I can see which (I will guess) supports the idea that the anti-cheat software isn’t starting the app.

It appears that the version included with VRChat is several versions old. I was able to download and install a version from Epic Games but it doesn’t seem to support VRChat so I removed it.

The VRChat version seems to be a console app. Does anyone know if there are command line options that can verify anything?

Did you ever figure out a fix for this? I’ve come across the same issue. Trying to launch VRChat from steam, both Steam VR Mode and Desktop (Non-VR) mode, both lead to it showing like its going to launch then instantly stops.

So far I’ve had no luck. I can run the client while testing from Unity which leads me to believe it is something to do with anti-cheat but that is purely a guess.

Some good news. I just tried today and it is working again. There were updates for the headset and for VRChat so I don’t know which (if either) fixed it but I’m back in PCVR.

Did you figure this out? im running into it now in the future kinda confused.