VRChat not responding (UnityPlayer.dll caused a Breakpoint)

Hi there,

Hope someone can help me, I’ve played lots of hours on VRChat and all of a sudden in early August 2021 upon loading VRChat the white box for VRChat.exe comes up for 2/3 mins then stops responding and closes (see pictures in the link below).

In the error log it mentions;

UnityPlayer.dll caused a Breakpoint (0x80000003)
in module UnityPlayer.dll at 0033:89f976fb.

and;

No mono DLL path set. This app is either running IL2CPP, or the crash occurred before mono was initialized.

I have been in contact with VRChat support, Microsoft support and now Unity support over the past month (almost 2 now). Hundreds of emails later trying all sorts of things to fix this VRChat Support team gave in and ask me to file a bug report with Unity support. But, and I quote Unity Support here “Unfortunately, I cannot give you further advice as it falls out of our area of expertise” blar blar blar. Not much help. I am still working with Microsoft support but we still can’t find any solution, so on the off chance I’m asking as any people as I can if they can help.

So here goes;

If you wish to see a copy of the Crash.dmp or error.log please feel free to use the links provided below.

crash.dmp

Crash dump decoded

error.log

I have no clue what or how this error caused itself to occur, everything was fine one day and broken the next. Nothing had changed software or hardware wise, it just simply stopped working.

PC specs
AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
MSI X570-A Pro
32GB DDR4/3200mhz
NVIDIA GeForce RTX 3080
Windows 10 Pro

Now for the fun list of things I have tried to solve this issue:

  • clean driver install
  • rolling back video drivers
  • rolling back Windows
  • full windows fresh install (6 times now)
  • running the latest version of Windows
  • installing on different drives
  • video stress tests
  • CPU stress tests
  • memory leak tests
  • running memtest86
  • running System File Checker
  • changing memory slots to pretty much every configuration
  • temperature monitoring (all totally fine)
  • no Citrix installed (this was a common issue with Unity)
  • no firewall/antivirus enabled
  • manual under clocking of RAM speeds in BIOS
  • ensuring all OC was disabled in BIOS
  • BIOS update
  • running several CMD based scripts found on other Microsoft forums to find and repair drive issues.
  • CMD regsvr32.exe /u UnityPlayer.dll
  • CMD regsvr32.exe UnityPlayer.dll
  • tried booting the PC in Clean Boot state
  • uninstalling / reinstalling the latest NVIDIA driver - but choose to “perform a clean installation”
  • restore defaults 3D settings in Nvidia control panel
  • overriding high DPI scaling behaviour on the VRChat.exe properties
  • running VRChat.exe with admin right directly (without steam)
  • disconnecting all peripherals except for the mouse and rebooting
  • verify the integrity of game files
  • reset to default avatar and world
  • clearing VRChat caches
  • turning it off and on again
  • reinstalling DirectX
  • swapped out FX card

Ironically VRChat works find on my old PC. Short of spending another £3500 (I don’t have) on another new PC I don’t know how to fix this and nor has anyone else so far.

There is this one article pointed out to me about games that use UnityPlayer.dll that crash constantly and includes VRChat among other Unity game.

Its a little concerning as one of the fixes was to RMA their CPU as it was failing at basic integer subtraction (still only within the unity game engine).

Anyway I’ve gone on long enough, any input or help is welcome and I thank you in advance.

I think I’m going to have to agree with one of the latest posts in that MS Answers thread that an RMA is the best way to fix. It sounds like you have a critical failure somewhere on your CPU die that only Unity seems to hit.

I’m unsure if we can offer anything here. Considering you’ve completely replaced the software on the system and it works fine on other machines, this is almost certainly hardware failure.

Is something preventing you from RMAing the CPU? The 5900X is very new, so you’re certainly covered under AMD’s warranty.

I have already started the RMA on the CPU :slight_smile:

the only thing that bothers me is Microsoft Support think its a software issue with DirectX and unityplayer.dll

This is part of the error.log and what Microsoft Support are referring to;

Module 1
C:\Windows\SYSTEM32\xinput1_3.dll
Image Base: 0x00400000 Image Size: 0x0001e000
File Size: 107368 File Time: 2007-04-04_185422
Version:
Company: Microsoft Corporation
Product: Microsoft® DirectX for Windows®
FileDesc: Microsoft Common Controller API
FileVer: 9.18.944.0
ProdVer: 9.18.944.0

Crash Report configuration:

  • App Name: VRChat
  • App Version: Unity 2019.4.29f1_0eeae20b1d82
  • Mono DLL:
  • Bug Reporter App Path:
  • Crash Report Path: C:\Users\ANDREW~1\AppData\Local\Temp\VRChat\VRChat\Crashes
  • Is Editor: false

Share your AppData\LocalLow\VRChat\VRChat\Unity folder please
also output_log files if you trust (recommended private)

This folder is empty as VRChat app crashes and hangs in the first 2/3 mins of loading.

Try Verify integrity of game files in Steam (Properties → Local Files)


Probably you are missing Windows SDK and/or Microsoft Visual C++ 2015 (Control Panel\All Control Panel Items\Programs and Features)

hi i have basically the same issue i have an
rtx 2060super
ryzen 1600 af
16 gig ram 3200mhz
i have done every thing that i could including the pervious list but nothing seems to work .
some other unity games have the same issue where they just use all the ram and crash and i get a UnityPlayer.dll caused a Breakpoint (0x80000003) error
i have done multiple clean installs of windows and the issue is not consistent with a specific unity version as i have seen all the unity games that i have and looked at their unity engine version
if you can help in any way i would appreciate it

2019.4.21f1 works gtfo
2020.3.5f1 no luck gang beasts
2019.4.8f1 works unbeatable
2019.4.4f1 no luck the vale
2019.4.13f1 works universe sandbox
2020.3.7f1 works amoung us
2019.4.24f1 works valhiem
2019.4.28f1 no luck phasmophobia

I have tried this many time over already

yosftag could you share your error log and dump file for VRChat so I can compare them