VRChat crashes when loading "MD Hub"

I can join other worlds fine, i just cant join this one… Ive tried everything including reinstalling the game but nothing works… heres a video of it: https://youtu.be/ZzqldoWA5rk

hmm, so since you can join other world just fine try clearing your content cache and textures and if that world continues to not work for you then a reinstall of vrchat might be needed (this includes clearing out vrchat’s registry keys) and if this doesnt help then it could maybe just be the world itself being unoptimized and you should contact other users and ask them if they’re able to join it and if they can try inviting you as that can also fix it sometimes

if all else fails then just dont join that world ig if its only happening on that world at least

tried that, didnt work, if it helps heres my system information:

Have you tried making a new instance? Try a private instance first.

tried with no luck

Have you ever been able to visit that world before?

yes i have