Very Silly Question, not covered in the FAQ

I’ve been having a very frustrating time trying to figure out what’s gone wrong with my ClientSim. I was able to test out stations a few days ago, then suddenly it stopped allowing me to do that. I have no idea what I did wrong, but now every time I want to test seats, I have to build the client, which takes a lot of time. Obviously, I’ve broken something. I tried downgrading, I tried completely reinstalling, I tried making a completely new world. Nothing works.

Please help me, build testing is very time consuming and I’d like to have the convenience back!

I tried making a completely new world

Would you mind trying one of the world template projects? That may help narrow down the issue to see if it’s an issue with project creation on your PC.

Make sure to check our console for any suspicious errors or warnings.

I will give that a try, thank you. If it means anything, I downloaded Unity on my Laptop completely fresh, with nothing ported over from my PC. When I went to test the station in the ClientSim, I had the exact same problem. I created a fresh world, made a cube for the floor, made another cube for the seat, made two empty objects for entry and exit, placed the entry on the top of the cube, the exit beside it on the floor. I entered ClientSim, and nothing. No prompt is showing up to use the seat, nothing at all. Clicking does nothing, pressing keys does nothing.

I… must be missing something. If the template project doesn’t work, I will retrace the steps I took on the laptop.

The template world didn’t work either.

Am I going crazy? Would it make any sense for it to be working in the build but not the clientsim? Especially when I, at one very brief moment, got it to work without needing to build.

I’d be happy to take a look at your Udon program! It appears to be invalid.

Oh no! I’ve not touched Unity until a week ago, I was using the VRC creator companion and the only thing I’ve done is clicked on the “add” buttons of the following:


The downgraded clientsim was anothe desperate attempt to fix things, but to no avail. The same thing happens, it just does not give me the interact prompt when approaching stations.

If there’s a way to fix this, I would be very grateful to know how!

In your previous message, the log displays the following error:

Could not load the program; the UdonBehaviour on ‘Cube (1)’ will not run.

What program was attached to the cube? It would be good to make sure it’s not an error in the program that’s causing the issue.

Oh my goodness now there’s something else wrong, my udon graphs are disappearing into nothingness and when I try to get them back I get errors… at this point I’m in danger of losing all my progress on a world, is there a way to fix my udon install??

Oh my, that sounds like there might be more than one problem!

It might be best if you try and tackle them systematically.

You mentioned that the template projects do not work for you, right? Fixing them may provide a solution for your old projects as well.

If you have any errors or logs, please share them!