SDK Core File Broken

There appears to be an issue with the core DLLs of the SDK which are rendering the whole kit unusable. As a result, I am unable to work on any of my world development projects or upload to VRchat. The errors being produced are within the core DLLs and show up with a brand new freshly made unaltered project, created by the official Creator Companion.

If you figure out the cause of this, please share it. I suspect that the path of installing the SDK on a fresh install of windows is missing something important. Like maybe it’s not actually installing visual C# 2019. Other speculation I’ve seen is related to unity package access.

I wonder if that dll is compiled locally or distributed. Please pick a dll, and give me the sha256 and SDK version. Virus total website will give you the file hash of a file you upload to scan. I ask for specific SDK version as I will probably have to wrestle with tools to make sure I get correct latest.

Looks like the project is missing non-VRC dependencies. Specifically, Cinemachine is missing (and possibly others) and as such the VRCSDK DLL’s which are dependent on it fail to load.

Does your firewall allow Unity to connect to the internet? Check the Package Manager (Window → Package Manager) and see what it says there.

Yes, Unity is allowed to connect to the internet.

The package manager showed Cinemachine was installed with version 2.8
I have now updated it to 2.9.7

SDK is still broken. Even a fresh install, direct download from the website.

For some reason Unity doesn’t seem to be installing dependencies. It should be installing them (including Cinemachine) automatically. Are you logged in to the Unity Hub? Are you behind a firewall or VPN?

Since you seem to be able to install them manually, try installing the missing dependencies that way. Click on the “In Project” button and select “Unity Registry” and it will list available packages to install. Here is a screenshot from my package manager for my avatar project to use as a reference:


You probably don’t need Oculus Android (unless you intend to build your world for Android)

I am signed in and it appears I do have dependencies installed.

For the first error about UniTask.dll if you select that particular error, is there any further details? Like in my project I have a Library\ScriptAssemblies\UniTask.dll

Oh I just noticed you’re using a World project.

Correct, it is a world project. My modeling skills are in structures such as buildings and starships, not avatars. Trying to get into world-building, but then the SDK broke halting all work on vrc worlds for me.

As someone just getting started, trying to follow the official guides, when this happens is a bit frustrating.

Most people’s use of unity for VRChat will be avatars, and not really creating from scratch but just importing a package and then uploading it.

I have a world project that I updated to 3.2.1 and it opens without the errors that you are seeing, so if I want to see the full error text for that unitask.dll I have to ask you about it.

I don’t have this problem so I can’t try anything on my end. I can’t try and see if an older version of the world ask works. I can’t try if the avatar SDK works. I can’t try and see if an older version of the avatar SDK works, specifically 3.1.13.

Well, I’ve already tried those but they all worked for me.

If this error popped up as a surprise and updating version of the SDK does nothing, that’s a good detail to share.

I probably should have just asked about the dll again but at this point I’m not sure on the name, maybe it’s unitask, or I’ve got unitaskers on the mind and it’s actually something like lemonzester.dll…

I have noticed that there is a lot of focus on making Avatars. Obviously, people are also making worlds, otherwise, VRchat wouldn’t have any place for people to visit with their avatars.
As to the errors being shown, they appear with 100% repeatability. At least for me.

I ran into a situation where an apparent update broke all of my world projects to the point where Unity would not even start. This prompted me to uninstall Unity and restart, and I figured the best way to start over was to re-download the SDK and go through the process step by step and that is when I came across all these errors.

I have not tried creating a new Avatar world to see if the issue is isolated to just world projects or not.
I could zip up the project for analysis.

Do that and I’ll see if I can take a look.

Here is a Dropbox download link where you can download the test project I created.

I downloaded and extracted your project. I deleted the library folder before opening it (this folder is automatically rebuilt by Unity if necessary).

I got the errors. Despite this, I was able to create and upload a blank level, and test it in VRChat, without issue.

So now I’m wondering:

What exactly happens if you try to use the VRChat SDK panel? Can you log in and can you hit “Build & Test”? If not, what errors do you get?