Returning user, can't connect to any world but the hub world

Edit: A VPN solved this!

Playing on PC with an Oculus. Steam, VRChat, and Oculus are all up to date.

Whenever I try to connect to a world, the world gets downloaded normally (if applicable), then initialized, and then the game gets stuck on the “connecting” screen for about a minute or two. After this point, one of a few things happen: In VR I get an error screen telling me I couldn’t connect, most times on desktop it suddenly reverts to “logging in,” or sometimes on desktop I see a static image of the world and a message telling me I timed out. In every case, I am automatically sent back to world download (which is skipped at this point), resulting in a loop that requires the game to be closed.

Here’s what I’ve tried so far:
Connecting to a world with 0 people (this is what results in the third outcome above)
Clearing my cache (Both in game and the \vrchat folder)
Disabling ipv6
Uninstalling VRChat
Using a different avatar
Forwarding ports
Making an exception for VRChat and EAC in Windows Defender
Restarting my PC
Running VRChat and EAC as admin