PC Avi appears in the ground for Quest users

I’m running into an issue where my friends running in Quest only say that my avatar appears mostly in the ground for them. It seems to be pretty consistent (Not limited to a world for example) and occurs for them even if they are seeing a VR Chat default fallback. It must be either something with my avatar or something with, like, SpaceDrag or something? I can’t see anything obvious that would cause this issue for Quest only.

Interestingly, I made a Quest compatible version of my avi that I could use as a custom fallback, and if I was in my PC avi and using that as my fallback, then it would appear in the ground just as others. However, if I actually switched avis into my Fallback, it appeared fine for Quest users then.

The avatars were identical save for a reduced polygon count, but the controllers and Avatar Descriptors were the same.

Any ideas?

I think I might have a solution. Still need to test it, but the thing I changed was that in the model configuration, I had the ‘Hips’ bone set to the actual Armature and not the true hip bone. That might account for the avi being in the ground but we’ll see.

That appears to have been the problem. Having the Armature as the Hip in my PC Avatar Configuration was throwing off world space for Quest users viewing my fallback.

Setting the Hip bone to actually be the Hip appears to have solved this issue.

Lesson: Be sure that your Avatar Configurations are using the proper bone/rig/armature associations after you import you model into Unity. :slight_smile: :carrot: