Fix for Quest Worlds only rendering in left eye

I’ve had this problem for ages and I wanted to give what the solution I found was.

At first I thought it was a shader that was causing the issue, but then I tried with just a default cube and it was still happening. Turns out the solution was that the Unity Build Settings tab wasn’t set to Android.

image

Hopefully this helps someone out.

5 Likes

I’ve Done this but some reason i still Presists do you have anyother help with issue?

" Double Vision " is a common problem that occurs. There are a number of reasons this could happen but here are 3 fixes that I have encountered when it comes to this.

  1. Delete your entire SDK in the project. Go down to the folders that say VRCSDK and delete them entirely. Then re-install / re-import your SDK once more. When it fully loads in , close your Unity project. Re-open your unity project and immediately re-publish the world once again. This has been known to fix most of the problems.

  2. Replace your skybox. This has only happened to one known individual and for whatever the reason was his default skybox was the known cause. Create your own material with your own images and go to Window > Rendering > Lighting Settings and replace your skybox as the first option. Re-upload your project.

  3. Replace all materials with some known working materials.

If you find any more problems please contact me and let me know so I can add on to this list and spread the word to others.