Error Building Avatar (2022.3.6f1)


I’ve been trying to upload an avatar for a friend of mine to use. However, I constantly receive a “Build Failed” error message.

Here is the message from console:

“VRC.SDK3A.Editor.VRCSdkControlPanelAvatarBuilder.Build (UnityEngine.GameObject target, System.Boolean testAvatar) (at ./Packages/com.vrchat.avatars/Editor/VRCSDK/SDK3A/VRCSdkControlPanelAvatarBuilder.cs:2060)
VRC.SDK3A.Editor.VRCSdkControlPanelAvatarBuilder.BuildAndTest (UnityEngine.GameObject target) (at ./Packages/com.vrchat.avatars/Editor/VRCSDK/SDK3A/VRCSdkControlPanelAvatarBuilder.cs:2391)
VRC.SDK3A.Editor.VRCSdkControlPanelAvatarBuilder+<>c__DisplayClass104_0.b__3 () (at ./Packages/com.vrchat.avatars/Editor/VRCSDK/SDK3A/VRCSdkControlPanelAvatarBuilder.cs:1775)
System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c.b__7_0 (System.Object state) (at :0)
UnityEngine.UnitySynchronizationContext+WorkRequest.Invoke () (at :0)
UnityEngine.UnitySynchronizationContext.Exec () (at :0)
UnityEngine.UnitySynchronizationContext.ExecuteTasks () (at :0)”

Any help would be much appreciated as this is such a headache!

also having the same problem. HAVE COMS I NEED TO DO ARRRRRRRRRRRRRR

so figuired out how to fix. Set your avi and in your inspector detatch your pipeline manager, and itll select a new one when you launch the build to upload.

so whenever i detach the blueprint id and go to build it still fails and just reattaches a new id to the avi

You’re going to need to look closer at the errors that you’re getting on your computer. It’s good that you’ve ruled out pipeline id though. One less possibility

Sorry for the delay! I completely forgot I made this post.

I did find a fix of it on my own. It involved making a whole new project in Creator Companion and importing everything from the last project into the new one. This seemed to have worked and I have yet to run into any issues.

I’m sure there are better ways but this one at the very least worked for me!