Avatars not working at all

So I haven’t gotten on in a while and I decided today was a good day to get back on. The problem is, as the thread title suggests, neither my avatars nor other people’s avatars load. I have even tried some of the starter avatars in the home world and they still won’t load. I have a Rift S and I have tried both steam version and oculus version. I have cleared every cache that I’m able to and have uninstalled the game multiple times (both through the clients and manually removed the file libraries themselves). The weird thing is that on loading the avatar I had selected before closing the game will load fine. However, if I go to another world or just select a different avatar I get the blue body loader and it just sits. Worth noting, I have tried both desktop mode and VR mode with no success My PC has never had this problem before and this issue has only popped up today.

My internet connection is not an issue, holds strong at 100Mbps and all drivers are up to date. My hardware meets or exceeds the minimum/recommended requirements. I’m not sure what to do here and I’m out of options with no understanding how to contact support.

Has anyone had this problem? Any help would be greatly appreciated!