Avatar Uploaded as quest version says PC only

I created a new avatar and published it to android only. Once I pull up the avatar on my profile, it shows that it is a PC only avatar. Additionally it shows on the upload window that the supported platform. Is there anything additional I need to do? Im using all the latest packages and unity 2022 updates. I’ll attach some images of what im seeing on my end as well below.


In the second screenshot the SDK isn’t clear to me if you’re in android mode or not. Maybe screenshot whole window specifically the title bar of the main Unity edit window.

The message under build and test is not correct for android.

Maybe reload the SDK? Otherwise check the console out for errors

I did not receive any console errors when uploading the avatar in android mode.
I also have the requested ss attached below.

You look like you’re set up to upload to Android… hmm.

Try swapping back to Windows mode, then to Android again. Then, upload one more time.

I’ve tried that and every time I upload the quest version, the PC would become and Error avatar. I have no clue whats going on, I even uninstalled and reinstalled the 2022 unity program. I’ve also tried a new avatar and issue still persists

I tried a new avatar sdk and tried to upload the android version and i get this console message.

Please follow how this guide video instructs you to capture the relevant errors:

Importantly, the first errors are usually the most important, so make sure you scroll to the top.

Got a new set of errors, 23 of them.


I also attached what would happen to my avatar after attempting to upload the quest version.

Delete AV3 manager and try again, the first error points to it trying to call something that doesn’t exist.

Which one?

I went into content manager and removed the Av3 and that got rid of the problem and errors and now a quest version exists. But others are saying that it is pc only. And upon the upload of the quest avatar the Windows avatar becomes the error avatar.

Honestly it sounds like your project has all kinds of crazy things going on in it. Could you try exporting just your avatar into a fresh new project with minimal addons?

Started a new project thru unity, only got VRC avatar SDK, Gesture Manager, and the avatar. Windows version uploads just fine, Android version is sending new errors.

Looks like its the VRLabs marker prefab? Pull that out and see if that works.

I think parts of that prefab don’t work on Quest, maybe?

The marker was enabled on the quest version so i deleted the prefab and now both a quest and windows version exists. Thank you for the help man.

Woo!! I’m really glad you figured it out!