Stream Camera Vsync in VR?

Hi, is there a way to enable vsync for the stream camera (on the desktop window) when playing in VR? I use a dual-PC setup for streaming/recording (PC1 plays the game, PC2 captures the monitor using a capture card). When I play in VR, the desktop window has screen tearing. This happens whether or not I use the stream camera. Screen tearing is always present no matter the combinations of resolution or framerate on the headset or on the monitor itself. I’ve tried using the fps, fullscreen and monitor launch options, but haven’t had any luck so far.

Do you see screen tearing on the monitor? Or just in recording?

I’m not sure how much of a performance impact it would be, but maybe have a copy of OBS capture the VRChat, and then export it with NDI? I believe NDI is something you have to add on to OBS. I forget how much bandwidth it uses, but the idea is that it’s fairly low latency.

I once fixed screen tearing by using active displayport to DVI adaptors. Maybe there is HDMI version if you need audio as well? I had a triple head setup with hd6970 and screen tearing was noticable scrolling in web browser.

it’s on both the monitor and in the recording/stream. i’ll look into the NDI way - i wanted to avoid using OBS on the VR PC if at all possible because of the resource usage but maybe that’ll be light enough. adapters might be another good call out! i use the HDMI port on my 3070 directly. i will say that no matter how many monitors i use though i still see the issue :confused:

Make sure it’s an active adaptor, those have a chip doing something.

Also you might be and to force vsync on in nvidia control panel

Try setting your capture card as the primary monitor. This is what I had to do on my dual PC streaming setup in order to avoid screen tearing.

So I’m not sure if it was just one of these or both (and I’m afraid to undo any of it lest it stop working lol) but:

  • I bought an active DP to HDMI adapter (since I had no clue if mine was passive, it didn’t seem to matter using that or my HDMI port directly), and
  • I switched my capture card (4K60 Pro Mk.2) to using an internal EDID at 1080p, instead of merged EDID at default settings

And the tearing seems to be gone now! I hope it stays gone. Thank you very much for the help!

(Before that, I had set Vsync in my NVIDIA settings and my capture card as main monitor, both to no avail. So I’m thinking it’s one of the two above that did it for me)