Is C# 8 supported? I don't see an option

From the VRChat docs: Unity 2022.3.6f1 includes many improvements such as faster iteration times, improved asset import times, much faster platform switching times, better editor stability, fully featured C# 8 support, a quick search feature, [and much more!]

As far as I can see I’m using C# 7.3 and can’t find any way to change that. I see a dropdown in Player settings re .Net version but it won’t let me select .NET Standard 2.1 if that is required or an option.

If you mean in the use of C# through UdonSharp, I guess that would be something to ask them on github with the migration to 2022