World Test build/Upolad issue. VRC Scene Descriptor issue

So I have recently tried to test run 2 diffrent world. One being Udon and the other being in SDK2, both seam to have the same issue. When i click eather the Test Build button or World Publish button it starts loading and after its done it shows me this messageimage
after which the unity stops and returns to the previous screen.
I checked and made sure there is nothing wrong with files by dowloading Udon files 3 times and making a brand new project with only Udon files where I only put in the scene a VRCWorld prefab and a cube for floor and thes same issue happened. Does anybody have any idea how to fix it?

1 Like

Try creating an Empty in your scene and adding a VRC Scene Descriptor component instead of adding a VRCWorld prefab.

I tried and the same thing happens as with a VRCWorld prefab

Also tried reinstalling vrchat sdk again and got these errors



When i tried building a test world i got the same error as last time

A Friend helped me out and he found a solution. Since i was messing with files recentlly my VRChat.exe location was not connected in the VRChat SDK settingsimage

So be sure to check your Client Path so it leads to an acctual VRChat.exe