VRChat World Not Being Able to Build and test

Hey so i recently went to try out making a vrchat world and im having a issue were i go to build and test the world it was “The VRCSDK build was aborted at the request of the ‘UdonSHarpBuildCompile’ VRCSDKBuildRequestedCallback” I’ve looked around for a fix and can’t seem to find one. Here is the Full Error Message

(The the VRCSDK build was aborted at the request of the ‘UdonSharpBuildCompile’ VRCSDKBuildRequestedCallback
UnityEngine.Debug:LogError (object)
VRC.SDKBase.Editor.BuildPipeline.VRCBuildPipelineCallbacks:OnVRCSDKBuildRequested (VRC.SDKBase.Editor.BuildPipeline.VRCSDKRequestedBuildType)
VRC.SDK3.Editor.VRCSdkControlPanelWorldBuilder3:OnGUIScene () (at Packages/com.vrchat.worlds/Editor/VRCSDK/SDK3/VRCSdkControlPanelWorldBuilder3.cs:173)
VRC.SDKBase.Editor.VRCSdkControlPanelWorldBuilder:ShowBuilder () (at Packages/com.vrchat.base/Editor/VRCSDK/Dependencies/VRChat/ControlPanel/VRCSdkControlPanelWorldBuilder.cs:130)
VRC.SDK3.Editor.VRCSdkControlPanelWorldBuilder3:ShowBuilder () (at Packages/com.vrchat.worlds/Editor/VRCSDK/SDK3/VRCSdkControlPanelWorldBuilder3.cs:43)
VRCSdkControlPanel:ShowBuilders () (at Packages/com.vrchat.base/Editor/VRCSDK/Dependencies/VRChat/ControlPanel/VRCSdkControlPanelBuilder.cs:329)
VRCSdkControlPanel:OnGUI () (at Packages/com.vrchat.base/Editor/VRCSDK/Dependencies/VRChat/ControlPanel/VRCSdkControlPanel.cs:214)
UnityEngine.GUIUtility:ProcessEvent (int,intptr)

1 Like

IIRC this error is not the main cause, there should be (at least one) other error in the logs, which should highlight why the build was aborted.
Do you have any error messages before that?

I figured it out it was something i was doing wrong not to sure but i fixed it thank you anyway

hi, how did you fixed it?

I had the same problem and I fixed it. In my console menu, there was an error that said a C# script was null. I keyword searched my assets for the name of the the script. Once I found and deleted it. The problem went away.