Unity "Build & Test" issue


As soon as I finished created my world and I clicked Build & Test , it runs for a while and this happens. I tried pressing Reload/Ignore again and again, nothing happens. I tried using both SDK2 and SDK3 but it does not make any difference, I tried searching for a solution on Google and r/vrchat on Reddit but came out empty handed as well. A Reditor commented however, to tell me to create a new scene and build a new world again so I did. Unfortunately it did not solve the issue.

PS: My Unity is at the latest patch, Unity 2019.4.29f1

SDK2 and SDK3 have components that do not play with eachother. gonna need to create a new scene with one or the other. installing them on top of each other borks everything

you can go into the folder create a backup. then remove all sdk stuff then import that into a new scene so you don’t have to rebuild everything. then import your SDK on a fresh untarnished project.

Or, you could do like I did, when the same identical thing happened to me, and was driving me insane, and nobody, in any forums, or help blogs would even offer any suggestions to remedy this annoyance.

Finally, after a ton of troubleshooting, the problem ended up being the SDK itself.

I had to drop back one version, to, “VRCSDK2-2021.07.12.18.53_Public”, and now I have my Local Testing back.

Although that same, “The open scene(s) have been modified externally” window still came up again, it didn’t matter anymore, because even though that window popped up again, right after it popped up, the VRChat window started, as it was supposed to.

Man it’s good to see I’m not the only one having that issue, yet nobody says a word.