Unable to Build and Publish an avatar

Hi! Sorry for posting another topic but I think I have another problem unfortunately! I’ve finished some work on my avatars and figured almost everything out, so I went to the VRChat SDK and tried to publish the avatar
The problem is though that it seems to do almost nothing? Every time I try to Build and Publish it, nothing happens. I tried to find some ways to fix it but I’m not sure if they even worked.
If you can help, I’d appreciate it!

You most likely are getting errors preventing the build of avatar to work properly. At the bottom of the Unity window a last error one should be shown, but you should look for the first one (red exclamation mark).

The errors I get are something along the lines of this? I’m not sure what it means exactly

Which version of Unity are you using?

I juggle between 20`18.4.30f1 and 2019.4.30f1

Which version of Unity are you using when you try to Build and Publish?

I tried both but neither would work

I think I’ve fixed it! Thank you for the help!
The problem before was that I needed to make a unity3d file using notepad, but it didn’t go to the correct location
I’ve found that the location seems to be this one:
C:\Users\USERNAME\AppData\Local\Temp\DefaultCompany\PROJECTNAME
You need to open notepad and save the file as customAvatar.unity3d, saving it as all files
I am having a bit of a trouble with the picture for uploading the avatar, but it should be a quick fix

Update: It shows me no visible image even though I’ve already chosen one for my avatar
image
This is the Game screen
image
Meanwhile this is the Scene screen