Udon Problem

I’m having an issue with uploading my project that I started today - all of the objects with an Udon behaviour attached to them is flagging up an error in the console saying “Could not load the program; the UdonBehaviour on (object) will not run.” The game will run a local test just fine, however the UdonBehaviour creates errors that I’m very confused about.

Essentially what it’s saying. There’s an error in your udon behavior which is stopping their operation.

it’s a fail-safe method that allows worlds to continue to work when scripts have errors.

You can try using cyanemu which might give you additional info when play testing in unity itself as to where the behavior is creating errors.

It’s weird, because cyanemu isn’t flagging up any errors, the Udon Behaviour doesn’t actually contain any script and is just used to synchronise the position of physics objects, build and test works perfectly, yet I can’t publish the world because the publish button is unclickable.

If you want you can send the world my way and I can try to see what’s going on.

Else a screenshot of the console log might help. It’s also possible you’ve installed udon sharp on a version of sdk3 that it’s not compatible with. In those cases the upload button is usually didabled.

thank you! i’ll make a .zip of it and put it on my dropbox

space lounge.zip - Google Drive It turns out my dropbox is full, but here it is. I have no idea what could be wrong.

Looks like it’s failing to load sdk3
I’ve also found several other optimization things that could use some work, so I’ve gone ahead and fixed those issues for you.

Oh, and I’ve added a better skybox and fake glass, so your windows look nicer and your skybox doesn’t look like it’s going to play some minecraft…

For future reference, if something doesn’t move, mark it as static,
this will make it be included in the lightmap and reflections.

With the exception of video players, and vrcworld itself. Since those have scripts on them.
Additionally, don’t make lights realtime, mark them as static and use a light group for lighting, this bakes the lighting so each object doesn’t need to calculate the lighting it should have. And massively improves performance.

it’s suuuuuper gorgeous now, but for some reason i can’t click any buttons in the VRCSDKWorld prefab when i run it, which is kind of a problem when i want to upload it! thank you for making everything pretty and better-looking!

also when you pick up the glasses, you can only pick up the drinks inside the glass, which is hilarious but i would like a container for my liquids.

use upload button in the vrchat control panel to upload, not the one in the game view also, don’t use the prefab, make an empty game object and attach the vrchat world descriptor to it.

Ive also included vrworld toolkit, top part of the screen it’ll help you set and fix common world things.

As for the glass check your pickup scripts I haven’t touched those only the material but maybe you’ll need to put the scripts up by one.

i’ve tried everything you’ve said and even reinstalling unity but absolutely nothing works, so i think SDK3 just hates my computer or something.

So, glass issue:

I accidentally marked them as static, un-doing that makes them move properly again.

Unable to upload the world issue:
image
Remove those 2, they’re not what you want to use
after that, make a new empty object and attach the following:
VRC Scene Descriptor.
and modify it like this:

After that add an udon behavior and use the VRCWorldSettings program source
image
are usually fine.

The reason you need to remove the VRCSDKWorld and VRCWorld prefabs is because those are used for something else. They shouldn’t really be used in scenes themselves.

Oh and if you need help in the future, feel free to hit me up on discord.
Nry_Chan#9983. I don’t mind hopping into a video call to show you the ropes.

1 Like

HOLY SHIT IT WORKS THANK YOU

i’ll hit you up on discord if i have more problems! i’m very shy on voice chat but i’ll do my best