Trying to make music play without emote

i got emote that plays music but i want just the music and no animation so i just toggle it on in the 3.0 menu and i can walk around with it playing on my avatar any body know how? and thanks

I believe you should be able to by making an animation that only activates the music, but doesnt play any animation on the rig. Just make it a toggle.

No clue how advanced you are in creating animations and stuff, but here’s a full fledged tutorial just in case.

Make an Empty as a child of your avatar, and give the empty an AudioSource using the VRC Spatial Audio Source component. It’ll look like this:
image_2020-11-04_170527

Then, disable the GameObject by clicking the checkbox at the very top left of the inspector.
image

Create a new animation for your avatar, and make it a 2-frame animation that enables the GameObject and doesn’t loop.
image

Create a new expression parameter that gets set to 1 when you want this sound to play. If you have several songs, you can use one parameter for each song by just giving them all a different “index”.
image

Add settings on your Expressions Menu that toggle the parameter when you click it.
image

On your FX layer controller for your avatar, pick an unmasked layer to put your animations on. If you’re not using your “AllParts” layer, you can add it to that. If not, you can make a new layer and set the weight to 1 by clicking the gear icon.
Layers are applied from the top down, so new layers should be at the bottom.
image

Click the “Parameters” tab, and add a new parameter with the name of the parameter you made earlier.
image

Create an idle state where no animation will play.
image

Click and drag your animations onto the controller to add new states for those animations. Right click your idle state, and click “Make Transition.” Drag the arrow to your state and left click to create it. Disable “Has exit time” and add a condition where your parameter equals the index you want.
image
Do the same for the other direction, but it should be “Not Equals” instead.

And that’s it. You can add other objects as children to that GameObject if you want them to show up at the same time as the audio.

Theoretically you could do this with the Any State system too but I had glitches with that so this will ensure you can only play one song at a time without any weird state jumps.

thank you this helps alot