Toggles and Emotes Broken

Does anyone know why some toggles and all emotes would stop working? the last version of my avatar had everything working fine, but after i added some more toggles, its just broken and I can’t figure out why.

Can you provide some more details? Assuming you’re using Avatars 3.0 there’s a lot that could be going on.

Before I added more toggles, I imported an updated version of my avatar from blender and attached the fx layer to that. The animations work in unity and the toggles look like they’re working in the debug menu in game, but nothing happens.
Another weird thing is that a few toggles work, but they look like they’re set up the same way as the ones that broke.

Have you tried testing your AV3 setup using Lyuma’s AV3 emulator? It might help you track down whatever’s going on.

It looks like the toggles are working according to this plugin, but the animations still arent working. they work when I preview the animation though.

Solved my problem. My animations were canceling each other out.