Toe problem

When i looking at toes at blender, they look like this
image
But when i look at them in unity, they vanished or turned into a dot
image
can anyone help me with that?

Is all the expected motion still there when manipulating the bones that do exist?

Those may be leaf/end bones that are added sometimes by Blender but don’t actually carry any weights. I think there’s an option on import settings when you select the FBX file to allow/disallow importing of leaf bones - I think it defaults to ignoring them since they don’t do anything.

This thing always enabled in my blender
image

In my experience, the Mecanim preview likes to hide bones it thinks aren’t relevant. If those toe bones aren’t assigned as a humanoid bone, they probably won’t show.

They are still there and will still deform.

How to assign them as a humanoid bone?
Im not good at blender…

So… Can anyone help me?

I’ve seen this happen usually when I’ve used the CATS plugin to ‘Fix Model’. Did you use CATS or are you just exporting though the File >Export > .FBX in Blender?

If you’re using the ‘Fix Model’ option, click the Wrench icon and ensure you have the ‘Keep End Bones’ option checked.

I got error when pressing it, even if reinstall CATS addon

I reccomend not using the fix model on CATS. It breaks many things whilst trying to be helpful. The only thing that I reccomend using on CATS is merging armatures. Everything else you can do by yourself without the addon

But how i can solve my problem without CATS?

CATS is not required to export your model and have it usable in VRChat. It helps because it does some clean up and has some nice optimization functionality, but you can still simply use File > Export > FBX (.fbx) in Blender. You just have to be sure you’re exporting the things you want.

What I mean by this is that you’ll need to ensure that you either have the ‘Active Collection’ option checked and that all the things in your collection are things you actually want to export -OR- actively select only the things you want exported (The mesh and the armature at a minimum) and use the ‘Selected Objects’ option. That’s usually what I do.

Bear in mind that if you have multiple meshes that the export will honor that, and when you bring your .fbx into Unity, the prefab will have multiple skinned mesh renderers for each mesh that is imported. You can ‘join’ meshes to eliminate this.

There are a few nuances to exporting and importing in this way, but you can absolutely do it without CATS.

Also, this option in the Export dialog should address the issue of no toe bones showing up after importing. You can check to see if this is being selected when you ty to Export using CATS as well, though I think there is an option in the plugin to do this. But maybe double-check anyhow. :slight_smile: