[SOLVED] "build and publish for windows" does not bring up the gui in the game window in unity

i open the menu to start a build and upload of an avatar, but the regular build button does not work. it just takes me to the default camera view instead of the avatar naming and publishing menu. i can still upload test builds just fine, because of that i know the avatar works, and there are no console errors at all. Removing the default camera results in “Display 1, No cameras rendering” being displayed. for some reason unity is not loading the gui menu and thumbnail camera. i have restarted the program, reopened the avatar, imported the avatar in and out, and edited the avatar, but still no change. i just want to upload my avatar.

What does the title bar of that editor window say about the unity version? Something is causing SDK to fail.

I forget what exactly happens when you run a newer Unity. Other thing to check would be like the SDK files, is this the newer VPM/Creator companion, or the older unity package with the SDK files all under assets?

Every time I’ve had a problem it shows in the log. But I did skip over 3.1.13

i am using 2019.4.31f, and i installed CC from the vrchat website just yesterday, installing the unity version it prompted me with.

i was able to upload a different avatar model just fine, but that model kept having something broken so i gave up and used a different one. now this one works perfectly, but i can only upload it as a test avatar.

Personally I’d try an older SDK version like 3.1.11, in the absence of an error message it’s not exactly an easily solved problem. Is this an avatar you created, or is there possibly of tools you’re not aware of being part of a unity package?

Unity has capabilities of editor only objects. I’m not sure how you’d look over the scene looking for them.

Personally when I’m playing with an avatar that is a prefab I unpack it into a scene. Then I can duplicate the scene and try removing random things.

i see. the avatar is one i got off of a website and modified a texture for, as well as remove some empty scripts that were causing errors.

i am just confused as to why i can upload a test version and it works perfectly, but i cannot build and publish normally. hopefully changing my sdk version helps.

i tried switching SDK versions and it did not work. i have tried messing with various other things, all to no avail. i really hate it when i have an issue that nobody else has had before me.

so it turns out i deleted an unused part of the avatar by mistake and that was causing this strange issue. apparently youre not supposed to delete unused assets even though theyre unused and not even connected to the asset being used?
man unity is a pain in the ass sometimes lol

I can think of two possibilities for what you mean.

First one is that you deleted an object inside the scene

Second is that after you’ve deleted a material or texture file, or maybe some other file

In general unity doesn’t like broken references, also certain systems are not directly connected. The expression menu can set numbers that the animator picks up on, but unity won’t know if something doesn’t have a menu. In fact the animator can set things too.

My least favorite is texture references in materials, convert something fancy to a quest shader and unity still thinks some of the now unused textures are still used. So I got in to a habit of making fresh new material and assign textures to it.