SDK3 Avatar Animation with Bone Transforms AND Material slot animation

So I am running into an issue with an avatar that has worked fine in SDK2, but is having issues in SDK3. Like the title says, the source of the issue is that an animation I want to play upon selection in the menu has both bone transform parameters and material slot change parameters, and the issue with this is that putting the animation on the Action layer will prevent the material slot parameters from working, but putting it on the FX layer seems to stop the bone transforms from working. I had the idea to split up the animation and run its components on their appropriate layers, activated by a single value detection, but that hasn’t worked. Any help on what I should do? I’m at a bit of a loss here…

I do this a lot. Basically, create one animation controller (You can use two, I just find it easier with one) and two seperate animations. One where it has the bone transforms, and one with the material animation.

I’m going to be using a model I did mainly texture switches with as an example.

Here are what my playable layers looks like:
image

This is what my animation controller looks like as far as layers:
image

As you can see, I separated emotes (my actions), my EmoteExpressions (FX layer for my action layer), and my eyes and mouth (my main FX layer).

These are my actions:
image

Let’s say we want to clap to have a happy animation, we would call VRCEmote = 1, which would trigger the layer to play the animation “clap”. Well, you can set up on another layer that if VRCEmote = 1, it will change the material, so in my EmoteExpressions I have this:
image
So when VRCEmote = 1, it plays the “happy” animation, which is just a material swap animation.

P.S. Make sure all layers are 100% blended.

1 Like

That is something I tried out actually. The problem I think came in because the animation that I wanted to play for changing the material slot is not just a 1 frame animation, it changes the material slot 8 times over the course of 8 or so seconds, and loops. and That I could not get working for whatever reason.

How are you making the animation? And do you know if it’s calling it for sure?