[Resolved] Visemes work in Blender and Unity, but don't work with lip sync

EDIT: With some help I was able to resolve this issue - my avatar needed VRMBlendShapeProxy and BlendShapAvatar on it. They would be blank and non-editable when I added them in myself, but I found I could export my avatar as a .vrm and reimport it, and the imported vrm would have all these parameters filled in. I had to manually assign the blend shapes in VRMBlendShapeProxy and re-export, and it worked!

Hello, this is my first post here!

I’ve been searching for the past two days on how to fix this issue, and everything I’ve found and tried doesn’t work for me. The visemes produced with CATS in Blender work fine there and in Unity, but when I export the .vrm file and test it out in Luppet (I’m planning to use this avatar for both streaming and VR Chat), the lip sync and eye tracking doesn’t work.
This is what I’ve done to get to this point:

  1. Made model from scratch in ZBrush & Blender.
  2. Used Mixamo to make the rig.
  3. Made shape keys in Blender for blinking and mouth movement.
  4. Used CATS plugin to create the visemes. Tested and they work fine in Blender.
  5. Exported the .fbx from Blender and imported into Unity.
  6. In Unity, checked the rig and made sure there is no jaw bone.
  7. Set Lip Sync to Viseme Blend Shape and assigned Body as face mesh.
  8. Assigned visemes accordingly. They work when manually adjusted in Unity.
  9. Exported the humanoid model using UniVRM-0.56.3. Tested the model in Luppet, and voice/cam lip sync and blinking don’t work.

Is there something I’m missing? This is my first time making a VR avatar, and from all the tutorials I’ve watched, it seemed pretty straightforward. I wasn’t expecting to run into any issues like this, and I’m really stuck. Any help would be appreciated ; n ; Thank you!

Here is my model in Unity, with me adjusting the viseme values:
hikobunny_visemes_unity

Probably it’s the basis shape key is the problem. I have problems with my shapekeys I made for vicemes and when I replaced a new “basis” shapekey, it fixed. If you have multiple of them or not. If not, I would recommend double check the shapekeys one by one

Im stuck on the same thing please can you explain or take screen shots in how to fix this . What are these shapkeys you speake of?

i don’t have the BlendShapAvatar and the VRMBlendShapeProxy i don’t know how to use it

Hi,
Are you new to shapekeys in general? If so, I suggest checking out some Blender tutorials about them:

If you’re referring to the specific issue I’m having where my shapekeys aren’t working when I export them to use in VRChat or Luppet, my edit at the very top of the post is pretty straightforward, I think.
If you don’t have VRMBlendShapeProxy and BlendShapeAvatar on your model, export as .vrm using UniVRM and reimport that same .vrm model you exported. It should now have those two properties and visemes be fully editable. Now, when you re-export as a .vrm again, your blendshapes should work perfectly.

Please refer to the edit at the start of my post. Those two properties did not appear for me until I exported my model as a .vrm and reimported the .vrm back into Blender.