Phys bone colliders vroid

Hello. I can’t see my avatar on Quest 3 because it has apparently too many phys bone colliders (20?) how do I reduce them in Unity? I don’t see any ‘armature’ options or anything. I don’t know how to do it. Also, I have 14k , almost 15 k polygons. i drastically reduced it but the quality has gone down so bad. by the way, i’m using VROID to make my avatar.

Are you certain that it’s the number of Physbone colliders that’s the problem? It seems that that shouldn’t be that big of a deal… but maybe so.

In any case, in order to reduce the colliders, you will need to go into your Armature and start looking at the bones for a Physbone Collider script. Simply select the script and delete it.

I don’t have it , I don’t have the option.

If the SDK panel says you have 20 physbone colliders, you have 20 of them to find

Typically they’ll be attached to the bones that they act on, but they could be elsewhere.

You may need to search the entire hierarchy of the avatar.

Do the colliders show up in the editor? By default it will be some green objects with a wireframe. Some pill shapes. If they show up in the editor you can narrow it down. Like click the object that contains the descriptor, then if you select the armature and they still show up, they’re in the armature.