Material Combiner Is Messing Up My Avatar

When I use the material combiner, I turns my avatar from the first picture into the second picture. The only problem area is the face. I’ve tried adjusting some of the atlas properties before saving but it always comes about about the same. Any idea how to fix this?

Not only the face, but also the eyes. I’m sure the mouth and teeth as well.

This is because faces of the mesh from two (or more) different materials use the same place on the UV map.

Try to Create Atlas with CATs plugin instead of Material Combiner.

Be sure you unpack the textures in Blender trough File > external data > Unpack all into files. this solved all my atlasing issues. ofc that is if you import a textured model into blender, it can apply the model textures but it can’t modify them and thus can’t atlas them properly.

1 Like

Unpacking the textures before generating the atlas fixed it for me.
I still found that the hair, eyebrows, eyelashes, and eye line lost their colour at this stage or on importing into Unity. Best workaround was to just re-colour them back to how they should be in Unity using the Poyomi shader settings.

1 Like