Masks hate me and i hate them >:c

so I have been working on my avatar for awhile and I have been using ONE controller on ALL playable layers. The controller has locomotion, FX, Action, and more and it works just fine.

Then I found out that the GOGOLOCO system updated to allow for scaling and speed and I decided I wanted to implement that. However it uses 5 controllers.

I tried dividing my controller first to get it set up but then stuff stopped working.
My locomotion layer which animates 10 legs, now only animates the rigged 2,
The Action Layer no longer uses the shapekeys or any non-humanoid bones,
And miraculously the FX layer is unphased by all this.

I started setting up masks but somehow regardless of what I do put in the masks or what I dont put in the masks, I cannot get them to function as expected. In fact I was only able to make things worse but having the entire avatar cease to function entirely.

I even removed all but the locomotion controller to see if they were interfering with each other and received no different effect.

I am beginning to think that there is a bug in the system, because I have tried literally every possible way to fix this with no success