I can't see my avatar, only if I use mirrors

I search for a solution of this everywhere, but I didn’t find anything useful. I can’t see my avatar when I am in vrchat unless I use a mirror, so if I try to see my body looking down to see my legs (as an example), there are no legs. Can someone help?

It sounds like your avatar mesh is set to either the MirrorReflection or PlayerLocal layer. Set it to Default instead

The layers of the avatar I have were in default always, the tags are simply untagged though. I don’t know if changing it to EditorOnly would do something

No, don’t do that, my picture is a bad example. All your stuff should stay Untagged.

Long shot possibility. Everything has some weighting to the head bone causing everything to be scaled out of sight.

That could be the problem, how do I check that exactly?

I think you’d either have to look at the settings in your model by selecting your model from your assets, and then going through the various settings there (Model,Rig,Animation,Materials) -or- maybe something in the model itself which would require some 3D Editing software (Blender, Maya etc).

However, I think it that were the problem, then you’d get a warning in your VRChat SDK Control Panel saying that your avatar is ‘smaller than normal’. It does scale checking like that.

If you can see your model when you run inside Unity but you can’t when you’re actually in-game, maybe looks at your materials - specifically your shaders. If you’re using a custom shader, maybe swap it for a default one just for testing. If you still can’t see yourself, at least you’ve ruled out your materials and maybe start looking at other things.

Can anyone else see you?

Yes, any other user can see me. I cannot see myself and the only way its using mirrors. I remember I mess with the shaders but I didn’t try to test on them to see if something changes. I will give it a try

Alright, I find out a few more things now. The avatar I am using is one that is controled using the right hand, I don’t have VR yet, so I am always on desktop mode. This avatar can said that works like a puppet.
The avatar has in unity something more in the shaders, four cubes that has a shader to be actually invisible, after changing that shader, the avatar is still invisible to me like usual, but not those four cubes, I can see the cubes. I am pretty sure that those four cubes are what represents the hands and the feet

Hmm. That sounds kinda weird. It still sounds like a shader issue to me, especially if you actually have shaders that make things invisible. The thing that sticks in my mind is that others can see you, but you can’t see yourself.
Are you sure that others have shaders enabled on other players’ avatars? Are the people that can see you friends such that they have all avatar features enabled? It might be that if other players have shaders disabled when they look at you, that’s why you show up to them.

Not sure there’s much more I can suggest except that it definitely looks and sounds like a shader issue so I’d definitely focus my debugging efforts around that.

Check the head-weighting issue by scaling down the head bone to zero in the editor. If your avatar disappears, that would be the problem.

Try creating a new material and assigning it to the avatar. Leave the material as the default shader and with no textures assigned. If this causes your avatar to become visible outside of mirrors, it strongly suggests a shader/texture issue.

Tripple check that the GameObject with the SkinnedMeshRenderer component attached (and not just the root avatar object) is assigned to the Default layer.

I am more sure now that can be a shader issue or something to mess with the head bone. Other users can see me even if they are no friends

I wil test that and keep updated the progress as soon as I am able to do that, thanks

I tried on my own and all turned in a lot of errors and not having other choice to do all the things I added to the avatar again, it will take me a lot of hours. I would thanks a little guide of how to scale down the head bone to zero in the editor, and also about the SkinnedMeshRenderer component.

image
I have this issue now

Phew, now its all better now, but I will still need some little guide to be honest

Backup your project regularly, always.

Download this file and save it somewhere in your project.

Then, on the Unity toolbar, click Tools->Generate Avatar Report. It will print some stuff in the console. Post that output here.

Its not a problem, I did a few more backups now and made sure they work quite well, so it won’t happen again. Now I am back at the initial problem

image
I scaled the head to zero and the avatar dissapeared. I guess that in that case is a head-weighting issue?

Sounds like all the vertices of your mesh have somehow been rigged to the head bone.

Did you make your avatar with blender? If so, go into edit mode, select all the vertices that aren’t part of the head. Next, click on the ‘Object Data Properties’ button on the right hand panel (the green triangle button), and under ‘Vertex Group’, select the head group and click remove.