How do i make an animation on action layer or fx layer that wont stop locomotion animations

I need to make it so all animations on my Action layer turn off all animation from my FX layer.
Right now if I press for example Shift+F8 to stick out my tongue and then open my radial menu and select any animation, my tongue will still be sticking out and any shapekey from the action layer isn’t enabled. i need to stop that from happening.

additionally I need very specific animation on my action layer to not turn off the locomotion layer animations. I want full walking animations including extra masked bones to move.

also still havent figured out why extra masked bones wont animate when fx animations are on