[HELP] No AssetBundle built/no AssetBundle has been set for this build

Hi there! As the title says, I’ve been getting this problem while trying to build and upload my first model to VRChat. One issue pops up with a yellow warning sign, the other with a red error sign. As expected, I’m using Unity, the recommended 2019 build. I think it’s worthy to mention that I’m not building a model from scratch, but rather retexturing one I’ve found.

I’ve tried many fixes mentioned on this forum. Converting DynamicBones to PhysBones doesn’t work – it only returns a message that states that there are no DynamicBones in the project. I’ve tried switching to Windows Standalone as well, however this just produces MORE errors (more severe than the last). I’ve tried to download FACS Utilities, which another user mentioned here, but… silly me, it doesn’t show up at the top (where VRChat SDK is located).

I have a difficult time following tutorials, so if you do answer this question, explain it like it’s my first time on Earth. :sweat_smile:
Also, this is my first post, so hi, VRChat forums!

Welcome to VRChat Ask!

It looks like you’ve tried quite a few things already, but one thing stood out to me - when you changed your build target.
If you’re trying to publish to Android, then that means it’s a Quest compatible avatar, and switching to Windows means you’re trying to publish to PC. Each of those build targets have distinctly different criteria for a successful publish.

I think the easiest thing to do up front is to ask you to which platform you intend to publish to and then to post a screenshot of your VRChat SDK Build screen so we can take a look at what the Validations say in there.