Help. avatar wont upload with weird error messages

So I’ve been trying to upload one of my first rigged avatars I made from scratch in blender.
So far everything seems correct. All the bones are good, and there are no major error messages in the sdk window.

when I try uploading it, it gets all the way to the point where it should be uploading and then it gives me like 3 to 4 error messages that I cant figure out.

heres a pic of the error log:

Ive tried everything from updating the SDK, to unchecking future proof to detaching the pipeline manager.

Both the SDK and my unity are up to date as well so I have no idea whats going on.

please help

Error: Not enough buffer space is available

is meaning.

Screen of the sdk window please

Pay attention to the last 2 error messages (Mesh Renderers and Material Slots).
And I recommend to detach ID.

Also remind about blendshapes:
https://images.app.goo.gl/tC8iFuETYC1rBy6U8

literally tried everything. I’ve uploaded avatars before with worse ratings and it still wont work.

I noticed in the error messages it gives me as its trying to upload, it says not enough buffer space available? I still have no idea whats going on

Can’t see all console messages in the picture.
Turn off the filter and maximize the window please

What is SDK version?

how large is your avatar/shaders? it doesn’t always look like it, but vrc does actually have a size limit for avatars… 21 mesh renderers looks… bad… really bad

Only 2 mesh renderers on it. Under 20k polygons. It’s a low poly kind of design so it shouldn’t be too big. I’ve tried making it smaller in scale and it doesn’t work either.

Hope this is what your looking for…

Im using unity 2019 and the avatar SDK3
been re downloading it many times with no luck





This is gonna sound sad but i think its now because I am using a MAC

That happened because you put both SDK2 and SDK3 in your project

edit:

But how? I’ve been opening new projects constantly reloading both the SDKs and unity, never adding both sdks.

Figured it out sort of. Literally had to change computers. Ended up using my friends PC to test and it worked fine.

So yeah don’t try and use a 2015 Mac to upload stuff to vrchat