Hand Gestures are not working

Lately I’ve been having problem while making avatars with the SDK 3.0, for some reason when I upload an avatar the hand gestures doesn’t work, the facial expressions does work but the fingers doesn’t move. I tried to make a new FX gestures later but it’s still doesn’t work. I don’t know how to fix it but sometimes it’s fixes out of the sudden. I don’t know what’s going on

2 Likes

I’ve got the same issue please help

Update: It seems that this problem only happens to Rindo so far, I’m not having the same problem with other avatars. If somone had the same experiance and found a solution please tell me how to fix it

I got this after I started launching my projects with the creator companion. On top of the hands not animating the gestures properly, I get misplaced teleports in worlds where multiple players teleport to another spot. Going to uninstall it all and just launch from the unity HUB.

So far, the only problems seen with this VRC-CC program is the Gesture Layer is somehow disabled.
The few ways to fix this issue is to have the animations from those gestures inserted to whatever face animations created. Or, create a new project and slowly import the necessary items. Not sure to those who have finger tracking…

Thank you @bic_blazen and @jimmy_raynor. I’m going to try yours suggestions and I will update it if they work or not. I hope you two have a great day

I have tried with one avatar and apparentally works but I will try with more

After some discord chatting. The problem is the new SDK doesn’t use masks anymore. So I had to change the mask to “none” on the left and right hand in the FX layer and that fixed my issue. I think this change is huge and then devs should let people know somehow.

3 Likes

Just tested this and it’s working. Thank you for sharing the thoughts and process.

@bic_blazen thank you for the info, that’s really good to know for next projects. Appreciate it

Been having this issue for awhile now. Can’t seem to find a fix for this issue. I tried removing the mask from my fx and gesture layer from the hands but that doesn’t seem to fix it either. Tried using the Creator Companion and it didn’t work. Originally started happening before I even knew creator companion existed. If anyone knows of a fix please let me know!

pardon my ignorance but where do I locate this as I have an avi where the hand gestures do not work at all. I used SDK 2022-08-29

The way I fix it was I replicated the Gesture layer in the FX layer, so basically you do the same with the face expression but you make for the hands.

1 Like

necroposting + bumping to hopefully push this solution up in search results because this is exactly what fixed my problem when i was doing a body swap of a model i already body swapped (hand gestures worked on old body swap but not the new one)

(i am so fucking thankful that you were able to find out the solution i’ve been pulling out my hair for like 2 days now)

Hey, for anyone who still has an issue with this. If you have a layer called “AllParts” in your FX Controller, make sure that there is no mask on it called “Hands Only” or “Hand Only”. For me that was the issue & I just set the mask on the “AllParts” layer to “None”.

Maybe this helps someone ^^