Get Position(Transform) Not Updating?

So basically i wanted to get the position of a object (in this case a pickupable one), but the position when read from the object is always its original (at game/editor start position). Moving the object either ingame, or in the editor, then reading the value via ingame ui or debug.log results in the original position.


(ignore the random extra stuff, its hooked up to a ui button ingame that just logs the position)

I tried just reading the position of a random cube in the editor that isn’t a rigidbody/pickup and moving it in the editor after hitting play but it also always returns the original position, not the current position. (i tried using local position instead as well, no difference).
I can set the position using udon fine, so i can teleport stuff around, but even after i set the position and it teleports, it still give the original position when i use get position on the transform.

The object(ball) is synced, although turning off sync didn’t make a difference.

How do i get the current position of a object that is moved?

EDIT:
So uh… somehow it is working now… apparently giving the object a parent somehow let its position update, i have no idea why. …? I’m not sure if this is ‘solved’ since i don’t really know why its working.