Can't upload to Android anymore

Hi, I have decided to start making avatars again after about 5 months or so. Since I last made one the control panel has been updated. However I am having issues with uploading to android. I am using Creator Companion and Unity version 2019.4.31f.

I have been doing my usual process, which has never failed me in the past and I am working with an avatar I have been using for a while (The regulus). I have no isues with PC uploads, but after clicking “Build & Publish” on the android build I simply get the error “Failed to build the Avatar, check logs for more details”.

I have checked over the logs and checked over the avatar multiple times but I just can’t figure out what is going wrong. At first I thought it was because I removed some physbones, but I tried it on the Quest optimised Nardo, that doesn’t require removing anything, and am still having the same issue. It seems like my ability to upload to Quest is practically unavailable.

Is there something I’m missing? I have been out of the loop when it comes to uploading avatars for a few months, but I wouldn’t have imagined it would have changed so much that I wouldn’t even be able to figure it out on my own.

Any help would be greatly appreciated. Thanks.

Can’t offer any help, sorry… just here to say I’m having the same issue.
Uploading to PC works fine but Quest upload seems to be bugged…

Did you happen to find out the issue?

Fixed it…
Go to settings in the SDK and uncheck “Future Proof Publish”.

1 Like

Glad to hear you fixed it. I actually did fix it but a different way. I just had to update Creator Companion.

I had no prompt to update it until a few hours later. I dont know why it took so long to show up but yeah, it was just out of date for me