Avatar toggle not turning on

Hello Everybody!

I tried to learn how to make toggles on an avatar the avatar is just simply a cube, I followed a tutorial and it seems like that toggles are not working

whenever I click them nothing happens and no sign that they are even on or off.

how can I fix this?

First of, I highly recommend using gesture manager.
It lets you test your gestures and animations in unity before pushing them to vrc.
And it allows you to debug your animation states.

Secondly, check these things:
image

  1. Make sure you have an expression menu and parameters setup.

  1. make sure your parameters are setup in your menu

image

  1. make sure your layer weight is set to 1 (under the layers tab, click the gear icon)
    Layers that aren’t set to 1 won’t work in VRC (Don’t ask me why, setting the weight to 1 just fixes it)

I’m very sorry for almost a whole month I think of not replying it was because I left the project but now I decided to come back to it, I tried out the tool and the toggles work inside the tool but in vrchat I can’t toggle them at all for some reason

thanks for replying again :slight_smile: