AV3 Hand movement when idle - any way to turn off? (Solved)

Hey all. So I have a very simple custom idle animation, it involves the avatar holding its hands together in front of it. Obviously, in the animation the arms are static. However, in vrchat the hands move very slightly, making the animation seem off:
wtf_hands

After watching a couple of tutorials on AV3 idle animations, I noticed that this doesn’t happen just for me: every single guide showed the arms to be flailing around a bit, but it did not interfere with the overall look, as those avatars had their hands by their sides.

Is there any way I can counteract this? Platform is desktop.
Things I’ve already tried:

  • set the idle animation back to the proxy_standstill ones (all 3 flail their hands around)
  • add VRC animator tracking state behaviour and turn off tracking control (didn’t help at all)
  • reconfigure the avatar rig (didn’t change anything)

Update: I found a fix!
The solution was to duplicate the vrc_AvatarV3IdleLayer (the one that goes in the Additive layer) and change the Upright Idle state’s animation from proxy_idle to my custom animation:

I also duplicated the vrc_AvatarV3ActionLayer (Gestures) and changed the Prepare Standing state’s animation from the proxy one to my custom idle.

Works perfectly! Will leave this post up in case anyone else runs into this issue as well.