2D Audio on Avatars

I am trying to add 2D audio to my avatar that rolls off to Zero after a certain distance
i know that i have done this before but i doesent seem to work anymore
the spatial curve goes from 2D to 3D after a certain distance
and in unity when i test it, it works fine!
but after i upload it its like VRChat ignores everything i set up and makes my audio go across the entire world

Why are you trying to adjust spatial blend instead of dropping the volume over the desired distance? Does that not work?

Here’s the intended flow for an effect like this, per the docs:

  1. Uncheck “Enable Spatialization” on the VRC_SpatialAudioSource component.
  2. On the Unity Audio Source component, adjust the Spatial Blend to be 100% 2D.
  3. Adjust the volume to fall off over distance using the Unity Audio Source component-- do not adjust the spatial blend.

yes i did exactly that but its like VRChat ignores the volume and has it at the same volume forever
and you do mean “uncheck “Enable Spatialization”” right? cause there is no “use spatialized audio” option.

Yep, you’re right-- its called “Enable Spatialization”. I was trying to recall from memory. :slight_smile:

Hmm, I see. That may be a bug, then. If you want volume fall-off, it looks like you may be restricted to spatialized audio.

It’d be good to create a test avatar that replicates this behavior and post the ID as part of a bug report on the Client Bug Reports Feedback board.

So i should make a dummy avatar with 2D Audio on it that rolls off to 0 using the Volume Curve with “Enable spatialization” unchecked correct?

Sounds correct!

The key is always to reproduce minimum case to make the issue happen to minimize other things affecting it.

Ok i created 2 Avatars with my methods i have used and described it in detail in a bugreport.
Hope this helps!

thx for the quick response.

Sure thing, thanks for the extra legwork on tracking down the issue. I can’t promise a quick fix or turnaround, but at the very least we’ve got it logged and reproducable. Thanks!

https://vrchat.canny.io/sdk-bug-reports/p/vrcspatialaudiosource-forces-audio-wholly-to-3d-if-curve-is-not-entirely-2d

The VRC_SpatialAudioSource script is busted in SDK2 right now, though it works for worlds in SDK3.